プロジェクト

全般

プロフィール

ArcGIS for DesktopでDEMから段彩陰影作成

数値標高データ(DEM: Digital Elevation Model)を可視化する手段として、標高値に応じた色を付ける段彩、光源を一方向(典型的には左上方向から高さ45度)に置いたときに生じる陰影があります。多くはこの両者を合成して段彩・陰影の画像を使います。

段彩と陰影の作成例(SRTM3データ)

作成対象範囲のDEMデータの読み込み

3秒(90m)間隔の数値標高データをArcMapに読み込ませます。SRTM3は1度四方の単位のファイル(hgt形式)で、ArcMapでは標準で読み込み可能です。読み込むとデフォルトでそのファイル内の最小値・最大値を上下限とする白黒のカラーマップが適用1されます。複数のファイルを読み込むと、ファイルごとに標高の最小値・最大値が異なるので以下の画面のようになります。

dem-01.png

SRTM3のラスタデータは、1バンド、符号付整数16bitでNODATA値は-32768となっています。

1 カラーマップの設定で、ストレッチタイプを[最小値-最大値]に変更、[最高/最低値を編集]にチェックを付け、最小値と最大値を各ファイルについて同じ値とするよう手入力することで揃えることもできますが、通常は後述のモザイクデータセットにして揃えます。

モザイクデータセット化して1つのDEMにまとめる

複数のDEMを1つにまとめるため、モザイクデータセットを作成します。[ArcToolbox] > [データ管理] > [ラスタ] > [ラスタ データセット] > [新規ラスタにモザイク] を実行します。
入力ラスタの指定で、使用するDEMファイルを複数選択します。選択の際、[▼]でレイヤにあるDEMを選ぶと1つずつしか追加できないので、その右脇にあるフォルダアイコンをクリックして、SRTM3のhgt形式ファイルを置いた場所を辿って複数選択すると便利です。
出力場所は、ファイルジオデータベースまたはファイルディレクトリを指定します。
ピクセル タイプは、SRTM3のhgtファイルの形式から調べて該当する16_BIT_SIGNEDを指定します。
バンド数は、SRTMのhgtファイルの形式から調べて該当する1を指定します。

モザイクデータセットとしてまとめられたDEMは次の画面になります。

dem-02.png

段彩を付ける

グレースケールとして表示しているDEMのカラーマップを、標高値に基づく色づけをして段彩とします。
モザイクデータセットとして作成したDEMをレイヤに追加し、カラーマップを指定します。

カラーマップを適用したDEMの表示は次の画面になります。

dem_tints_colormap-02.png

カラーマップは自分でも定義できます。

陰影を作成する

DEMから陰影を作成します。いくつか方法があるので試して見ます。

レイヤプロパティのシンボルで陰影起伏効果を使用

段彩をつけたレイヤのレイヤプロパティで、陰影起伏効果にチェックを付けます。

レイヤプロパティ-シンボル-陰影起伏効果.png

次のような表示が得られます。

dem_tints_hillshade-01.png

画像解析の陰影起伏を使用

DEMをもとに、新たに陰影のレイヤを作成します。
[ウィンドウ]メニュー > [画像解析]を選択します。「画像解析」ダイアログが表示されます。

  • 陰影起伏を生成する基となるDEMのレイヤを選択状態にします(チェックボックスは関係なさそう)。
  • オプションで光源方位、光源高度、Z値の倍率を設定します。
    • DEMを投影変換しておらず地理座標系のみ設定している場合、画像解析処理は、座標系がXY軸が緯度経度単位なのでZ軸(高さ)も度単位とみなすため正しい陰影が生成されません。標高のメートルを度に単位変換する係数を指定します。係数はおおよそ0.00001(1度を100kmとみなしたとき)ですが、緯度によって若干変わります。次の米Esri社のブログに緯度に応じた係数が公開されています。
      http://blogs.esri.com/esri/arcgis/2007/06/12/setting-the-z-factor-parameter-correctly/

  • 陰影起伏のカラーマップを指定します。グレースケールにしておくと汎用性が高いです。
  • 解析を実行すると陰影起伏が生成されます。

dem_hillshade-01.png

グレースケールの陰影起伏の上に段彩のレイヤを重畳して表示し、段彩のレイヤの透過度を50%あたりに設定するとよい感じになります。

dem_tints_hillshade-2.png

画像解析の陰影起伏レイヤは一時的なものなので、画像解析の結果がよければ保存します。

陰影起伏(Hillshade)ジオプロセッシングツールを使用

3D ExtensionまたはSpatial Analysis Extensionで提供されるHillshadeジオプロセッシングツールを使った陰影の生成です。
  • [ArcToolbox] > [3D Analyst ツール] > [ラスタ サーフェイス] > [陰影起伏(Hillshade)]
  • [ArcToolbox] > [Spatial Analystツール] > [サーフェイス] > [陰影起伏(Hillshade)]
    のいずれかを選択します。

入力ラスタではDEMを選択し、出力ラスタは陰影起伏を生成する先を、光源方位、光源高度、Z値の倍率を指定します。
Z値の倍率は、先の画像解析での指定と同じです。Hillshadeのダイアログを次に示します。

hillshade_tool-01.png

生成された陰影は次のようになります。カラーマップを見ると256段階のグレースケールになっています。

dem_hillshade-02.png

ここで作成した陰影起伏を、先の段彩と重畳すると次の画面になります。

dem_tints_hillshade-3.png

クリップボードから画像を追加 (サイズの上限: 1 GB)