プロジェクト

全般

プロフィール

Eclipse セットアップ

Windows 7 64bit

Windows 7 64bit版およびJDK 8u92 64bit版への Eclipse Mars.2(4.5.2)のインストールメモ

Eclipse IDE for Java Developers

本体のインストール

https://eclipse.org/downloads/ より "Eclipse IDE for Java Developers" Windows 64bit版をダウンロードします。

eclipse-java-mars-2-win32-x86_64.zip

Eclipseを使用するユーザーの読み書き実行可能なフォルダに展開します。
C:\Program Filesの下に展開すると、eclipseを実行したユーザーの権限でディレクトリ内に書き込みができず動作不良を起こすので、C:\Users\<自分のユーザー>\の下に適宜フォルダを設けて入れるとよいかと思います。

日本語化プラグイン(pleiades)のインストール

http://mergedoc.osdn.jp/index.html より、"Pleiadesプラグイン・ダウンロード"から最新版のpleiadesをダウンロードします。

pleiades.zip

  • 2016-04-30現在、安定版の1.6.0以降Mars向けに修正がいくつか入っているので最新版の方をインストール

次のフォルダを作成します。

<eclipseインストールフォルダ>\dropins\MergeDoc\ecilpse

pleiades.zipの中にあるfeaturesフォルダとpluginsフォルダを、今作成したフォルダの中にコピーします。

<eclipseインストールフォルダ>
  +-- dropins
        +-- MergeDoc
              +-- eclipse
                    +-- features
                    +-- plugins

次の設定ファイルを修正します。

<eclipseインストールフォルダ>\eclipse.ini

+ -Xverify:none
+ -javaagent:dropins/MergeDoc/eclipse/plugins/jp.sourceforge.mergedoc.pleiades/pleiades.jar

eclipseを-cleanオプション付きで実行します。
無事立ち上がれば、いったん終了し、次は普通にeclipseを実行します。

初期設定

インデント

デフォルトではTABコードでインデント(1 TAB = 4 SPACE)する仕様になっているので、空白でインデントするよう設定します。

[Window]メニュー > [Preferences]でPreferences画面を開き、左側ペインで[Java] > [Code Style] > [Formatter] を選択、右側ペインでアクティブなプロファイルに編集可能なプロファイル(既定のプロファイル名には[built-in]が付いている)を選択し、なければ新規にプロファイルを作成します。
編集可能なプロファイルを開き、[Indentation]タブを選び、タブ・ポリシーに[スペースのみ]を選択、インデント・サイズは4を選択します。

キーバインド

emacsキーバインド

[Window]メニュー > [Preferences]でPreferences画面を開き、左側ペインで[General] > [Keys]を選択、右側ペインでScheme欄をドロップダウンリストから[Emacs]を選択します。

JavaFX開発環境

e(fx)clipseプラグインのインストールと設定

インストール

Eclipseでは、JavaFX開発環境のプラグインe(fx)clipseが追加インストールできるように用意されています。
[Help] > [Install New Software...] で Install画面が表示されるので、[Work with:]欄にドロップダウンリストからOxygen - http://download.eclipse.org/releases/oxygenを選択します。多数のプラグインがリストされるので、type filter text の箇所にfxと入れて絞り込みます。

  • EclipseのバージョンによってOxygenの部分の文字列が変わります。

install_efxclipse-1.png (e(fx)clipse プラグインの選択)

[e(fx)clipse - IDE] にチェックを付けて、[Next]をクリックしインストールします。

Eclipseを再起動します。

トラブル(Oxygen)

2017-09-02時点、Eclipse Oxygen に、e(fx)clipseプラグインをインストールし、再起動したところ「Multiple problems have occurred」エラー発生

install_efxclipse-2.png (インストール後の再起動で発生)

再び再起動したところエラーは出なくなったので、しばらく様子見。

設定

Eclispeを再起動後、[Window]メニュー > [Preference] を実行します。Preferences画面が表示されます。
左側ペインでJavaFXを選択し、右側ペインで SceneBuilder executable欄に別途インストールしたScene Builder実行ファイルへのパスを設定します。

使用方法

Eclipseの[File]メニュー > [New] > [Project]を実行します。New Project画面が表示されます。
[JavaFX] > [JavaFX Project]を選択します。

eclipse_newproject_javafx-1.png (Eclipseの新規プロジェクトでJavaFXの雛形)

Javaプロジェクト作成ウィザードが表示されます。

eclipse_newproject_javafx-2.png (Eclipseの新規プロジェクト作成 - 場所と名前)

プロジェクト名と保存場所を指定して[Next]

eclipse_newproject_javafx-3.png (Eclipseの新規プロジェクト作成)

ここはデフォルトのまま[Next]

eclipse_newproject_javafx-4.png (Eclipseの新規プロジェクト作成 - パッケージ名、FXML使用)

パッケージ名をcom.torutk.axes3d、FXMLを使うプロジェクトを作成、ルートコンテナにはAnchorPane、ビューの名前をAxes3dView、コントローラの名前をAxes3dViewControllerとする場合の記述を次に示します。

eclipse_newproject_javafx-5.png (Eclipseの新規プロジェクト作成 - パッケージ名、FXML使用(記載済み例))

これで[Finish]を押します。生成されるファイルは次の様になります。

Axes3d
  +-- src
  |     +-- com.torutk.axes3d
  |           +-- Axes3dViewController.java
  |           +-- Main.java
  |           +-- application.css
  |           +-- Axes3dView.fxml
  +-- build.fxbuild

実行すると、空のウィンドウが表示されます。

問題解決メモ

pleiadesプラグインで日本語化するとEclipseが起動しない

Windows 7 (64bit)にeclipse 4.3 x64を入れたときの事例

eclipse 4.3 x64をWindows 7に入れたときの事例です。
最初、RAMドライブのTEMPディレクトリ下にeclipseを展開し、pleiadesプラグインをdropinsに入れて起動することを確認した後、eclipseディレクトリを丸ごとC:\Program Files\Java\の下に移動しました。そして、eclipseを立ち上げてみたところ、次に示すエラーダイアログが表示され起動できませんでした。

pleiades_error.png (Pleiades初期化時にエラー)

原因

Windows Vista以降、C:\Program Files以下はユーザーからは書き込みできない領域となっています。これはWindows OSのディレクトリポリシーであり、アプリケーションは実行ファイル等変更しないファイルをC:\Program Files以下に置き、設定、データ等の変更するファイルについてはそのマシンを使うユーザー間で共通なものはC:\ProgramData以下に置き、ユーザー固有なものは、C:\Users\<ユーザー名>\AppData\Local以下等に置くようになりました。

ところが、eclipse(pleiadesプラグイン)は、プログラムファイルと同じディレクトリ構造に変更するファイルも置いています。そのため、C:\Program Files以下にeclipseをインストールするとこの問題が発生します。

解決策1

eclipseを、C:\Program Files下ではなく、ユーザー固有のディレクトリかC:\ProgramData下に置きます。

解決策2

eclipse\configurationディレクトリ以下のアクセス権を、一般ユーザーが書き込み可能なように設定します。
例)Usersグループにフルコントロールを付与します。

この解決策のデメリットは、起動時にワークスペースの選択を毎回尋ねられる点です。

解決策3

eclipse\configuration\config.ini に以下を追記します。

osgi.configuration.area=@user.home/.eclipse/org.eclipse.platform_4.3/configuration

pleiadesプラグインでホバー表示が文字化け

Windows 7 64bit版・JDK 8u92 64bit版にeclipse 4.5.2 64bit版

Ecilpse Mars.2 Java Developer版に、Pleiades プラグイン(Ver. 1.6.7)を入れた環境で、新規Javaプロジェクトを作成し、新規クラスを作成し、その上でJava SE標準クラスのAPIのホバー表示(日本語)をすると、日本語が文字化けします。

hover_japanese-1.png

回避策

プロジェクトのプロパティーで、左ペインで[リソース]を選択、右ペインでテキスト・ファイル・エンコードを[その他]で[UTF-8]に設定することで、文字化けが解消されました。

→ JavaDoc APIリファレンス(日本語訳)がUTF-8で記述されているのに対して、EcilpseのWindows版はデフォルトではMS932円コーディングのためエンコードが不一致で文字化けするものと思われます。

ただし、ソースファイルのエンコーディングがUTF-8に限定されてしまいます(Javaの場合は望ましいと考えますが)。

クリップボードから画像を追加 (サイズの上限: 1 GB)